Risolto statistiche fantacalcio da celle disorganizzate

pellegrino

Nuovo utente
22 Agosto 2021
12
1
office365
0
Ciao a tutti,
Parliamo di fantacalcio. Ho appena finito di preparare il foglio per il prossimo campionato di calcio, ci stanno le tabelle con tutte le sfide, la tabella con le classifiche, i play off ecc ecc. Ora mi è venuta voglia di creare una serie di tabelle per generare delle statistiche esempio la partita che ha generato più punteggio, la squadra che nell'arco di campionato farà più gol in una partita, il totale di tutti i punteggi di tutte le partite per capire chi ha fatto il punteggio più alto (che non va di pari passo con chi vincerà il campionato) ecc ecc. Ho allegato una piccola parte per capire come posso prendere le informazioni dagli incontri senza colmare con espressioni lunghissime ogni casella oppure mettermi per ogni squadra per ogni partita e fare =D4 o =F13 (celle casuali) per fare le mie statistiche. Nell'allegato per esempio se voglio calcolare il bologna quanti gol ha segnato nella prima giornata e quanti nella seconda giornata oppure il punteggio che ha raggiunto nella prima giornata e nella seconda oppure ancora se voglio mettere un V (che sta per Vittoria) se nella prima giornata ha vinto o meno, visto che la tabella che riporta i risultati non ha un incolonnamento omogeneo come posso risolvere in modo più veloce?
 

Allegati

pellegrino

Nuovo utente
22 Agosto 2021
12
1
office365
0
Ciao, mi serve in primis per il secondo (avere un file di statistiche e risultati quanto prima) e in successivamente per imparare ovviamente
 

pkrome59

Utente assiduo
Expert
26 Settembre 2015
2.603
145
61
Reggio Calabria
Office 2019
177
Buon giorno, se ho capito bene copia le seguenti:

In K3:
=SE(CONFRONTA($J3;INDIRETTO("R"&AGGREGA(15;6;RIF.RIGA(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3&":A"&CONFRONTA(K$2;$A$2:$A$1000;0)+7))/((SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;;5)=$J3)+(SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;1;5)=$J3));1)&"C"&1&":R"&AGGREGA(15;6;RIF.RIGA(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3&":A"&CONFRONTA(K$2;$A$2:$A$1000;0)+7))/((SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;;5)=$J3)+(SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;1;5)=$J3));1)&"C"&2;0);0)=1;INDIRETTO("F"&AGGREGA(15;6;RIF.RIGA(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3&":A"&CONFRONTA(K$2;$A$2:$A$1000;0)+7))/((SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;;5)=$J3)+(SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;1;5)=$J3));1));INDIRETTO("H"&AGGREGA(15;6;RIF.RIGA(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3&":A"&CONFRONTA(K$2;$A$2:$A$1000;0)+7))/((SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;;5)=$J3)+(SCARTO(INDIRETTO("A"&CONFRONTA(K$2;$A$2:$A$1000;0)+3);;1;5)=$J3));1)))
da trascinare verso destra fino a L3 e poi giù;

In M3 da trascinare verso destra fino a N3 e poi giù, altra formula che troverai nell'allegato;

In O3 e P3 altre formule da trascinare giù, che troverai nell'allegato;

In Q3 da trascinare verso destra fino a R3 e poi giù, altra formula che troverai nell'allegato.
Ciao.
 

Powerwin

VBA Expert
Supermoderatore
17 Marzo 2016
8.839
245
vicino a Milano
2019 e 365
301
Ciao a tutti, pkrome59 @pkrome59 come già scritto altre volte, per delle formule, solo da copiare e incollare, non serve allegare file posta pure le formule delle altre celle
 

pkrome59

Utente assiduo
Expert
26 Settembre 2015
2.603
145
61
Reggio Calabria
Office 2019
177
Ciao Powerwin, ho allegato il file perché le formule in M3; N3; O3, P3 e Q3 sono diverse e lunghe.

Al fine dell'ottenimento del risultato finale è opportuno mantenere il file.
Mi scuso e colgo l'occasione per rinnovarti un cordiale saluto.
P.S. se non puoi ripristinare il file lo farò io.
 

Powerwin

VBA Expert
Supermoderatore
17 Marzo 2016
8.839
245
vicino a Milano
2019 e 365
301
perché le formule in M3; N3; O3, P3 e Q3 sono diverse e lunghe
pkrome59 @pkrome59 saluto, lo capisco, ma dobbiamo facilitare anche chi frequenta il forum tramite cellulare e magari non vuole scaricarsi il file per vedere quelle formule
se non puoi ripristinare il file lo farò io.
per questa volta ripristinalo tu, io non posso, cerchiamo solamente di limitare l'uso di allegati a situazioni davvero particolari, non dove serva un semplice copia e incolla di formule, questo l'utente dovrebbe saperlo fare
 

pellegrino

Nuovo utente
22 Agosto 2021
12
1
office365
0
Innanzitutto grazie pkrome59 @pkrome59 a prescindere.. ovviamente non ci ho capito nulla ma sarà la sfida per capire bene come hai potuto realizzarla. Scarto e Indiretto ancora non le conoscevo quindi mi ci vorrà un po' per capirla. A presto
 

pellegrino

Nuovo utente
22 Agosto 2021
12
1
office365
0
Buonasera, una sola domanda rispetto alle istruzioni inviate che, ringraziando ancora pkrome59 @pkrome59 per la possibilità di imparare, grazie anche a l'opzione valuta formula, volevo sapere se è possibile integrare per le formule che danno come risultato "N", "V" e "P". A seconda delle informazioni riportate se c'è un modo di far sì che finché una cifra non viene inserita (nella matrice) la casella con la formula dia come risultato vuoto altrimenti le intere statistiche vengono fuori come tutte "N" e non è il massimo per la grafica da vedere.
 

pkrome59

Utente assiduo
Expert
26 Settembre 2015
2.603
145
61
Reggio Calabria
Office 2019
177
Ciao, se ho capito bene, ad inizio formula aggiungi la parte in rosso e alla fine chiudi con una parentesi tonda.


=SE(O(C4="";E4="";NON(VAL.NUMERO(C4)));""; formula )
 
Ultima modifica:

pellegrino

Nuovo utente
22 Agosto 2021
12
1
office365
0
ok ho assegnato la coppa alla miglior risposta.. ma è già impostato RISOLTO quindi o l'ho già fatto io e non me lo ricordavo oppure l'ha fatto qualcun altro al mio posto. Ma per me va bene lo stesso
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!