Risolto Raggruppare Redditi a Scaglioni

Terio

Utente abituale
6 Gennaio 2021
319
30
50
Arce
2016, 2019
27
Io mi butto, ma appoggiandomi ad un range definito:
S =SOSTITUISCI(DESTRA(Foglio1!$B$2:$B$10;5);"50001";"9999999")*1
la formula in C2 da copiare in basso:
=MATR.SOMMA.PRODOTTO(--(A$2:A$15<=INDICE(S;RIF.RIGA(A1))))-SOMMA(C$1:C1)
ma per 38 caratteri ci vuole (per me) più di una notte :LOL:

buon riposo a tutti
 

lukereds

Excel/VBA Expert
Staff
17 Luglio 2018
5.129
145
Milano
www.formazione-milano.net
2013, 2016, Ol
415
ciao a tutti, più che un quiz di excel mi pare un "quesito della Susi" della settimana enigmistica Crepa_pelle

PS: I "da" sono in parte incollati ai numeri (es. da7501) in paerte no (da 2501 ). E' voluta questa cosa?

Cancello la domanda, già risposto
 
Ultima modifica:

Gianfranco55

Utente senior
5 Novembre 2015
12.121
1.445
66
Valdagno
excel 365
1.249
ciao
ma a me non funziona questa (sfalsa di in riga )
=CONTA.SE(A:A;">"&DESTRA(B2;5))-SOMMA(C3:C$11)

ma visto che molti nelle formule hanno taroccato l'ultimo dato
se metto in B10 .......75000
questa va benissimo
=CONTA.SE(A:A;"<="&DESTRA(B2;5))-SOMMA(C$1:C1)
 
Ultima modifica:

paoloard

Utente assiduo
Expert
18 Febbraio 2018
4.044
245
fra BO e FE
www.riolab.org
365
526
Ciao a tutti.
Direi che si può chiudere qui.
Classifica vale per le formule corrette (salvo errori):

Quindi coppa a Lukereds. Mancando una versione 365, un like a Pkrome (secondo). :applausi:

La mia soluzione:
versioni pre 365:
selezionare l'intervallo C2:C10, immettere la seguente formula matriciale (confermare con Ctrl+Maiusc+Invio):
=FREQUENZA(A2:A15;1*DESTRA(B2:B9;5)) con le due graffe fanno 38 caratteri

versioni 365:
in C2 stessa formula che svilupperà in basso la matrice soluzione. 36 caratteri
 

Allegati

Ultima modifica:

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!