Risolto Formula per riscrivere i dati in colonna

Uzzo

Utente junior
Original poster
10 Luglio 2020
63
2
8
Mac 2021
Buongiorno, vorrei mettere in colonna i dati contenuti in una matrice, è possibile?
In allegato il documento con semplificato il risultato voluto.

Vi ringrazio
 

Allegati

  • Ordine dati.xlsx
    15,9 KB · Visite: 14

Uzzo

Utente junior
Original poster
10 Luglio 2020
63
2
8
Mac 2021
Ad integrazione della precedente richiesta, il risultato desiderato è quello in F2.

Grazie
 

Terio

Excel/vba Expert
Staff
6 Gennaio 2021
16.238
3.379
1.345
53
Arce
2016, 2019, 365
Con il MAC non si può usare FILTRO.XML, per cui maniera classica:
F2
=INDIRETTO(TESTO(QUOZIENTE(RIF.RIGA(A1)-1;4)+2+(RESTO(RIF.RIGA(A1)-1;4)+2)*1000;"R0C000");0)
da tirare in basso,
ciao.
 

Uzzo

Utente junior
Original poster
10 Luglio 2020
63
2
8
Mac 2021
Maledetto MAC.,

Funziona, grazie mille, pensavo fosse più semplice.

Provo ad applicarlo alla matrice con cui sto lavorando che è molto più estesa, dovrei farcela.

Grazie Terio
 

Terio

Excel/vba Expert
Staff
6 Gennaio 2021
16.238
3.379
1.345
53
Arce
2016, 2019, 365
Provo ad applicarlo alla matrice con cui sto lavorando
Dinamica in base alla matrice:
=SE(RIF.RIGA(A1)>CONTA.VALORI($B$2:$D$5);"";INDIRETTO(TESTO(QUOZIENTE(RIF.RIGA(A1)-1;RIGHE($B$2:$D$5))+2+(RESTO(RIF.RIGA(A1)-1;RIGHE($B$2:$D$5))+2)*1000;"R0C000");0))

Ciao.
P.S.
Non usare il forum come una chat, hai 30 minuti per modificare i messaggi ed eventualmente integrarli
P.P.S.
Maledetto MAC
Puoi sempre passare a 365 🙃
 

Uzzo

Utente junior
Original poster
10 Luglio 2020
63
2
8
Mac 2021
Premesso che posso ovviare al problema riscontrato spostando la matrice, tuttavia sarei curioso di sapere perché non funzioni la formula se la matrice dati comincia in una cella diversa da B2, pur spostando anche il riferimento A1 in modo tale che lo schema rimanga lo stesso benché traslato.
 

pkrome59

Utente assiduo
Expert
26 Settembre 2015
3.056
933
145
64
Reggio Calabria
Office 2019
Buon giorno, altro modo:

=INDICE($B$2:$D$5;RESTO(RIF.RIGA(A1)-1;4)+1;QUOZIENTE(RIF.RIGA(A1)-1;4)+1)
da trascinare giù.
P.S. In rosso va inserita la tabella di riferimento; in giallo il numero di righe della tabella, tutto il resto della formula rimane come lo vedi.
Ciao.
 
  • Like
Reactions: Terio

Terio

Excel/vba Expert
Staff
6 Gennaio 2021
16.238
3.379
1.345
53
Arce
2016, 2019, 365
sarei curioso di sapere perché non funzioni la formula se la matrice dati comincia in una cella diversa da B2
Perché devi modificare i coefficienti correttivi:
=SE(RIF.RIGA(A1)>CONTA.VALORI($B$2:$D$5);"";INDIRETTO(TESTO(QUOZIENTE(RIF.RIGA(A1)-1;RIGHE($B$2:$D$5))+2+(RESTO(RIF.RIGA(A1)-1;RIGHE($B$2:$D$5))+2)*1000;"R0C000");0))
Usa quella di pkrome59 @pkrome59 (ciao) che è più facile:
=SE(RIF.RIGA(A1)>CONTA.VALORI($B$2:$D$5);"";INDICE($B$2:$D$5;RESTO(RIF.RIGA(A1)-1;RIGHE($B$2:$D$5))+1;QUOZIENTE(RIF.RIGA(A1)-1;RIGHE($B$2:$D$5))+1))
resa dinamica con l'altezza della matrice, basta modificare solo quella ($B$2:$D$5) in tutte le sue ricorrenze,
ciao.
 

Uzzo

Utente junior
Original poster
10 Luglio 2020
63
2
8
Mac 2021
Buonasera, curiosando qua e la ho scoperto che vi è una formula che consente di fare quello che ho chiesto in maniera molto semplice. La funzione Stack.vert.
Tanto per dare un piccolo contributo... :)
 

Terio

Excel/vba Expert
Staff
6 Gennaio 2021
16.238
3.379
1.345
53
Arce
2016, 2019, 365
curiosando qua e la ho scoperto che vi è una formula che consente di fare quello che ho chiesto in maniera molto semplice. La funzione Stack.vert.
Curiosando sul tuo profilo aggiornalo con la 365 per fare in modo che ti vengano proposte soluzioni corrispondenti 😉

Ciao.
P.S.
Come d'altronde detto al #6
 

Uzzo

Utente junior
Original poster
10 Luglio 2020
63
2
8
Mac 2021
Grazie, ho aggiornato il profilo. In realtà ho la versione 2021 Mac, è l'equivalente della 365?