Domanda Calcolo celle nulle

napoleon

Nuovo utente
31 Maggio 2021
8
1
Excel 2016
0
Buonasera,

sto cercando di creare un file per il calcolo della media nei test che faccio però quando i ragazzi sbagliano vi devo scrivere "nullo" per ricordare che lì c'è un errore e non vale (il test è su 3 tentativi).
Quando calcolo la media finale ovviamente va in errore oltre al fatto che io ho settato la media sulle "3" prove e se non metto nulla ovviamente il risultato è sballato. come posso ovviare a questo problema? Inoltre invece mi potete dire se la formula che ho inserito per la media della velocità è esatta? Grazie
 

Allegati

Berna11

Excel Expert
Moderatore
20 Febbraio 2016
9.938
945
Latina
Excel 2010
1.135
Ciao
comincia a togliere l'errore
metti in F3:
=SE.ERRORE(40/E3;0)
trascina in basso
Fai lo stesso sulle altre colonne con errore,
 

Gianfranco55

Utente senior
5 Novembre 2015
11.730
1.445
66
Valdagno
excel 365
1.189
ciao
oltre alla formula di Berna
tu vuoi sistemare quei nullo
una tecnica è usare la funzione somma
abbinata a se errore
in Q
=SE.ERRORE(SOMMA(E3;G3;I3);0)/3
in R
=SE.ERRORE(SOMMA(F3;H3;J3);0)/3*3,6

stessa tecnica per le altre due colonne

perchè usare somma?

perchè il se errore valuterà singolarmente i numeri e dove trova l'errore
mette 0
perciò
se scrivo
=SE.ERRORE(E3+G3+I3;0)
sarà
SE.ERRORE(#VALORE!;0)
e il risultato diventa 0

Se scrivo
=SE.ERRORE(SOMMA(E3;G3;I3);0)/3

diventerà
SE.ERRORE(SOMMA(1;2;#VALORE!);0)
SOMMA(1;2;0)

risultato 3

spero essere stato chiaro
 
Ultima modifica:

paoloard

Utente assiduo
Expert
18 Febbraio 2018
3.842
245
fra BO e FE
www.riolab.org
365
505
Ciao.
Tenuto presente i giusti suggerimenti di Berna11 @Berna11 e di Gianfranco55 @Gianfranco55 , occorre tenere presente che nel calcolo della media i valori =0 non dovrebbero intervenire nel calcolo.
Per cui, per una corretta media in colonna Q, direi di modificare il denominatore:
=SE.ERRORE(SOMMA(E3;G3;I3);0)/CONTA.NUMERI(E3;G3;I3)

E così per tutte le altre formule.
 

paoloard

Utente assiduo
Expert
18 Febbraio 2018
3.842
245
fra BO e FE
www.riolab.org
365
505
Dipende da cosa vuol fare lui. Infatti chiede se ha fatto bene le medie, non ne è del tutto sicuro.
Domanda a N @napoleon :
nella media vuoi comprendere i nulli oppure no?
 

napoleon

Nuovo utente
31 Maggio 2021
8
1
Excel 2016
0
Buonasera a tutti, scusate l'attesa ma sono stato impegnato.
Rispondo alla domanda di Paolo.
a me serve sapere la media dei test validi sulle 3 prove.
Se faccio 3 prove ed una la sbaglio, ad esempio, perchè il ragazzo è cascato, la prova è nulla e considero solo le altre due quindi la media è solo sulle due valide!
poi se ne fa 3 corretti la media è sui 3 validi.

Ho provato le formule di Paolo ma mi escono risultati sballati....
Ho provato la formula di Gianfranco e, nella colonna "Q" riesco ad ottenere il risultato corretto anche quando scrivo "nullo"
nella colonna R mi restituisce "0" quando nelle colonne che deve conteggiare c'è la scritta #valore....

come si può ovviare?
 

Gianfranco55

Utente senior
5 Novembre 2015
11.730
1.445
66
Valdagno
excel 365
1.189
ciao
impossibile con il tuo conteggio le mie riescano giuste
comunque devi gestire l'errore come ti ha detto Berna
poi i conti tornano
=SE.ERRORE(40/E3;"nullo")
nelle colonne F-H-J-K-N-P

poi
usa
=SE.ERRORE(SOMMA(E3;G3;I3);0)/CONTA.NUMERI(E3;G3;I3)
=SE.ERRORE(SOMMA(F3;H3;J3);0)/CONTA.NUMERI(F3;H3;J3)*3,6

adeguandole alle esigenze per le medie
 

Sostieni ForumExcel

Aiutaci a sostenere le spese e a mantenere online la community attraverso una libera donazione!